ColdFusion 9 Install on RedHat with JBoss

 

Just wanted to pass along some notes from doing a ColdFusion 8 upgrade to ColdFuison 9 64 bit JBoss install on RedHat this week.
 
First off, all went fairly well, but I think you might find the tips below helpful.
 
First get all the software:<br />
- CF 9  Linux 64 bit<br />
- CF 901 Updater 64 bit <br />
- CF 9 Cumulative Hot Fix  (optional)
 
The ColdFusion Installation docs are what we generally followed:<br />
<a href="http://help.adobe.com/en_US/ColdFusion/9.0/Installing/WSc3ff6d0ea77859461172e0811cdec18c28-7fbd.html" target="_new">Deploying ColdFusion 9 on JBoss Application Server</a>
<br />
You can get the Updater and the Hot Fixes following the below links:<br />
<a href="http://www.adobe.com/support/coldfusion/downloads_updates.html" target="_new">ColdFusion Updaters</a><br />
<a href="http://kb2.adobe.com/cps/862/cpsid_86263.html" target="_new">ColdFusion 901 Cumulative HotFix 1</a>
 
Install CF9 using the J2EE install option.
 
Once installed you are left with the decision to test the install, which would put you down the road of expanding the ear and war per the instructions.  However, the 901 updater executable requires you to apply it to an archived war file.   So, you might want to apply the updater before expanding the ear and war and moving the resulting ear directory into JBoss's deploy directory.
 
We did not know the CF 9.01 updater required an archive, and we had already deleted the war file, so we had to recreate the war, apply the updater, re-exand and swap out the new war with the old war directory.  So, just keep that in mind if your doing a complete install as we were doing.
 
Here are the complete docs for installing the CF 9.01 Updater:<br />
<a href="http://www.adobe.com/support/documentation/en/coldfusion/901/cf901install.pdf" target="_new">Installing ColdFusion 9.01</a>
 
Updating your Settings from ColdFusion 8 to ColdFusion 9
<br />
So to move the settings we followed the instructions inside the link below:<br />
<a href="http://help.adobe.com/en_US/ColdFusion/9.0/Installing/WSe9cbe5cf462523a0-b18e31f121c8f9f003-8000.html" target="_new">Migrating ColdFusion Settings for J2EE installations</a>
 
So by following the above we did the following:<br />
- copied all the neo-* files from ../web-inf/cfusion/lib out of the 8 install, and placed then in the ../web-inf/cfusion/lib/cf8settings directory inside 9 <br />
- adjusted the runmigrationwizard and the migratecf8 settings in ColdFusion 9 cfusion/lib/adminconfig.xml, change them to true <br />
- restarted ColdFusion and entered the Admin to trigger the Migration
 
All the ColdFusion 8 settings were brought over.  The migration wizard allows you to filter out settings if you don't necessarily want them all.
 
That was it, all went well, and all the settings were brought over and all datasources connected.